X

Mac Version of 'Spore' Requires Intel Chip, OS X Leopard

bleahy
9 Comments

Posted September 3, 2008 - By bleahy

Just a friendly reminder to any Mac users that are planning on picking up Will Wright and EA's newest creation, Spore, when it releases on September, 7 2008... make sure you have an Intel-based Mac running OS X Leopard.

The system requirements have been known for a while, but we wouldn't want anyone to run out to the store only to have a computer that cannot possibly run the game.

Are you planning on getting Spore? We are.

Source

Mac Version of 'Spore' Requires Intel Chip, OS X Leopard
http://www.g4tv.com/thefeed/blog/post/688901/mac-version-of-spore-requires-intel-chip-os-x-leopard/
http://files.g4tv.com/images/blog/2008/09/03/633560494973915639.jpg
BlogThread_688901

ADVERTISEMENT

Blog Tags

g4tv.com
  • International Sexy Ladies Show: Messy Cat Fight

    Posted: January 27, 2010

    644,696 Views | 00:49

  • Sara Underwood's Naked Bike Ride

    Posted: June 22, 2011

    1,316,284 Views | 05:20

  • Laser Snake Robots, More Mars Rovers and BigDog Is Back

    Posted: September 25, 2012

    1,290 Views | 03:00

  • NBA 2K13 Launch Trailer

    Posted: October 4, 2012

    5,601 Views | 01:53

  • Casual Vomiting - Web Soup Investigates

    Posted: March 30, 2011

    7,570 Views | 02:52

AdChoices